Export to parquet query doesn't return

ronshronsh Vertica Customer

I run export to parquet query. The files are created as expected after a few minutes, but the query keeps running and doesn't return any answer (I've waited for hours).

_ EXPORT TO PARQUET ( directory = '/data_parquet/recvTimeDate_2020-02-20_half_hour') OVER
(partition by startMeasurementDate order by startMeasurement) AS SELECT
startMeasurement,column1,column2,column3, column4,column5,column6,column7,column8,
column9,column10,column11,column12,column13,column14,recvTime from public.table1 where
recvTime BETWEEN '2020-02-20 10:00:00' and '2020-02-20 10:30:00' ;_

Any idea what's the problem?




  • Options

    @ronsh How many rows does "public.table1" have? Do you see any errors in the vertica.log?

  • Options
    anatolianatoli Vertica Employee Employee

    @ronsh You can also try querying v_monitor.udx_events as described here to monitor export progress (exported rows, rowgroups, etc.)

  • Options
    ronshronsh Vertica Customer
    Thanks guys, but we already fixed it :)
    It was a linux issue.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file