The Vertica Forum recently got a makeover! Let us know what you think by filling out this short, anonymous survey.
Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

COPY data from S3 using IAM_ROLE

rkg112rkg112 Vertica Customer

Hi, I had an IAM_ROLE setup where it has access to S3. I am testing the COPY command from my local vagrant image where Vertica is running. I want to connect to S3 via IAM_ROLE instead of setting up the AWS_AUTH and session tokens. I tried this on Redshift using the IAM_ROLE to copy files from s3 to Redshift. It worked. But I can't found proper documentation to use IAM_ROLE with COPY command. Is there any solution for this?

dbadmin=> COPY power FROM 's3://test/' ON ANY NODE IAM_ROLE='arn:aws:iam::xxxxxx:role/vertica_s3' PARQUET;
ERROR 4856: Syntax error at or near "IAM_ROLE" at character 55
LINE 1: ... power FROM 's3://test/' ON ANY NODE IAM_ROLE='...


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file