Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

AHM not advancing

Hi,
we are unsing vertica comunity edition version 9.0.1 single node installation.
We are having problem with Ancient History Mark (AHM), the mark is not advancing, I've tried to restore from backup and AHM is still not advancing.
In the same installation I've another trouble (I don't know if it is related to AHM) in some situation the db fail doing analyze row count.
I've tried to force the AHM allignement with SELECT MAKE_AHM_NOW(true); and mark is advancing without any problem, what can I do?

Here are the rows on vertica.log About AHM

2021-04-26 03:09:18.001 AnalyzeRowCount:7f7179fcb700 [Command] TMTask: row count analyze - start
2021-04-26 03:09:18.006 ManageEpochs:7f70fdd03700-a000000001a2ee [Txn] Begin Txn: a000000001a2ee 'Manage Epoch'
2021-04-26 03:09:18.008 ManageEpochs:7f70fdd03700-a000000001a2ee [EE] (a000000001a2ee) Could not advance AHM
2021-04-26 03:09:18.008 ManageEpochs:7f70fdd03700-a000000001a2ee [Txn] Rollback Txn: a000000001a2ee 'Manage Epoch'

Here are the rows on vertica.log about PANIC
2021-04-22 17:47:00.166 AnalyzeRowCount:7fc4017c9700-a0000000015a2a [Txn] Begin Txn: a0000000015a2a 'analyze_row_count'
2021-04-22 17:47:00.167 AnalyzeRowCount:7fc4017c9700-a0000000015a2a [Main] Handling signal: 11
2021-04-22 17:47:00.582 AnalyzeRowCount:7fc4017c9700-a0000000015a2a [Main] Received fatal signal SIGSEGV.
2021-04-22 17:47:00.582 AnalyzeRowCount:7fc4017c9700-a0000000015a2a [Main] Info: si_code: 1, si_pid: 0, si_uid: 0, si_addr: (nil)

Answers

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.