Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

Management console and license information

Hi Vertica people!
My MC is not showing all the information on Setting.no access. I can get into the settings tab but there is no data on all the side menu (tuple mover, security, Epoch mgmt etc..) - screenshot attached.
and on the messages I have a "critical" message from vertica saying that "could not get license information.."

Is it related?
How do I give the license information? I think it is overdue maybe how do I renewal it? its a community edition.
Do you think that this is connected to the face I cannot access any of the settings?

Best Answer

  • Accepted Answer

    Hey!
    I reinstalled the license as you mentioned and uninstalled MC and installed and imported the db again and now it works!!!
    Thank you very much!!
    Keren

Answers

  • screenshot of the problem:

    1.JPG 37.8K
  • Jim_KnicelyJim_Knicely Administrator
    edited June 4

    What user are you logging into MC as? The admin user you created when you installed MC? Maybe it'd help to reset MC?

  • Hi Jim!
    Thanks for answering me.
    The user of the mc is admin.When I reset MC no change and further more I have another MC installed on another box of Ubuntu and when I run the mc there the same issue.The settings are not avaialable and the critical message of the license is showing.
    When I try to reach vertica license people they are not helping.What is my next step? how can I solve this?
    Do I need to install the db again? what kind of license is inserted in the community edition? who do I enter license info when I dont' have it?
    I didn't install the initial installation so I don't have any license info and it appears Vertica doesn't also because its the community edition.

    Please help!
    Keren

  • Jim_KnicelyJim_Knicely Administrator

    MC doesn't need a licence. When you import a DB into MC, the license info comes from there.

    Can you log into the database directly? (i.e. using vsql). Then you can check the license that is installed:

    Viewing Your License Status

  • Hi Jim
    Yes I can log into the db directly and also I can log to MC but I cannot see any of the settings tab.I have another MC installed on another box and the same issue there.both the db and the MC are 10.x version and the critical warning is attached to this message.Really weird I cannot see any of the resource pool settings or any other settings of the db. here is the output of the license from vsql and attached the warning in the MC + the settings problem - you can see there that I can't see the setting at all just the menu from the left and thats it.no settings.

    DISPLAY_LICENSE

    Vertica Community Edition
    2011-11-22
    Perpetual
    1TB CE Nodes 3

    Please advise....I am desperate.Installing MC or importing the db again didn't work.

    2.JPG 41.4K
    1.JPG 87.9K
  • Jim_KnicelyJim_Knicely Administrator

    Maybe try reinstalling the license?

    Using admintools on one of tghe nodes:

    [[email protected] ~]$ admintools -t upgrade_license_key -l /opt/vertica/config/licensing/vertica_community_edition.license.key -d verticademos
    Upgrading the license key for database verticademos
    License installed with at least partial success.
    Details:
    Success: Replacing vertica license:
    CompanyName: Vertica Community Edition
    start_date: 2011-11-22
    end_date: Perpetual
    grace_period: 0
    capacity: 1.00TB
    Node Limit: 3
    
    
    with vertica license:
    CompanyName: Vertica Community Edition
    start_date: 2011-11-22
    end_date: Perpetual
    grace_period: 0
    capacity: 1.00TB
    Node Limit: 3
    
    

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.