Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

Problem running install_vertica

Hi guys,

I had installed the server rpm (7.0.2.1) on my RHEL machine and I tried to choose an alternate installation directory by doing this:

> rpm -iUvh vertica_package --prefix=/home/samuel/Vertica

I think this went fine and it reported successful, but when I tried to run the install_vertica script in /home/samuel/Vertica/sbin/, it went into problem, error on not finding /opt/vertica/oss/python, so I went in to edit the install_vertica script to change the python path to /home/samuel/Vertica/oss/python, but I got stuck again at the next error, which says 'no module named vertica'...

Hope somebody could help, thanks.

Regards,
Samuel

Edit: I just tried another approach, I created a symbolic link on /opt, pointing to /home/samuel/vertica, and install the rpm package, without using the --prefix. This works, but when I run the install_vertica script, I got into another error, complaining invalid permission on /opt/vertica directories on the localhost, I have set the permission to 755, but it still does not work. Wonder if it is something to do with the symbolic link...

Comments

  • Do you run the script as root ? 
  • yes, ran as root.
  • You can try run the script in trace mode , this will help you find root cause, below are the step that need to take in order to switch the script to run in trace mode :   

    o       Open  the install_vertica script   in editor

    o       after the line that include this text “"# Description: install Vertica database on cluster” add new line that include set command “set –x” (without inverted commas)

    o       save change and run the script , this will print you useful debug information about the script execution

     


  • Hi!

    Vertica distro packages its just emulation of packages. Do exactly as in docs if you don't wanna to fix a lot of things manually.
  • Hi Samuel,

    Hm...  The Vertica package should not be relocatable; for better or worse, the path "/opt/vertica/" is baked into the installation of both Vertica and the third-party libraries that we bundle.  Please install it to that location.

    If you really can't do that, maybe you could use a bind-mount rather than a symlink?

    I'll check with folks on our end about why the package allows relocation.

    Thanks,
    Adam
  • Also, note that the RPM is installed by the install_vertica script on all nodes other than the first one where the installation is performed, and that we don't provide a way to pass arguments through install_vertica to the remote RPM installations.

    If this is an important use case for you, certainly let us know.  This is the first time I've heard of someone wanting to use this RPM feature with Vertica.  If it's secretly something that lots of people want to do, we will of course take a harder look :-)  I would imagine it being more common for development setups; people who test Vertica often seem to have Ubuntu or Debian on their personal system, which means 'apt', which doesn't have good support for specifying a package prefix.
  • I also wanted to install vertica in another location than /opt/vertica and stumbled upon the same problems. So, guys! Please, have a look into your code and add the options for rpm with --prefix and --relocate (otherwise please disable it totally, because first I ran the installation of the rpm with these options and now I have a problem: I cannot uninstall the rpm).
  • -bash-4.1$ rpm -qip vertica-7.1.1-0.x86_64.RHEL5.rpm
    Name        : vertica                      Relocations: /opt/vertica
    Version     : 7.1.1                             Vendor: Vertica (an HP Company)
    Release     : 0                             Build Date: Thu 16 Oct 2014 10:05:56 PM CEST
    Install Date: (not installed)               Build Host: vdev.verticacorp.com
    Group       : Applications/Databases        Source RPM: vertica-7.1.1-0.src.rpm
    Size        : 459273949                        License: Commercial
    Signature   : (none)
    Packager    : Vertica (an HP Company)
    URL         : http://www.vertica.com
    Summary     : Vertica High Performance Database
    Description :
    Vertica Database v7.1.1 release 0

    Relocations should say:
    (not relocatable)

    check it: http://www.tecmint.com/20-practical-examples-of-rpm-commands-in-linux/

  • If somebody wants to remove the package installed with --relocate option then you should type: sudo rpm -e --noscripts vertica

  • this is the message that appears after installing Vertica with the relocation:

    Preparing packages for installation...
    vertica-7.1.1-0
    Shutting down vertica services for upgrade
    /var/tmp/rpm-tmp.6EvFll: line 6: /opt/vertica/sbin/vertica_service_setup.sh: No such file or directory
    ln: accessing '/opt/vertica/oss/python/lib/python2.7/site-packages/': No such file or directory

    Vertica Analytic Database V7.1.1-0 successfully installed on host diascld27

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.