Configuring and starting Spread

I already have vertica installed in AWS and after days of troubleshooting I discovered that I needed to -T option in install_vertica to configure point to point. Can I get some help on:

 

1) how to re-configure spread to use -T (point to point)?

2) how to restart?

 

I tried using 

 

[[email protected] ~]# /opt/vertica/sbin/update_vertica -s host1,host2,host3 -r ./v/vertica-7.1.1-0.x86_64.RHEL5.rpm -u vertica -T --failure-threshold NONE

 

but I see this message when I run the update:

 

-----------

Running upgrade logic
No spread upgrade required: /opt/vertica/config/vspread.conf not found on any node
Installation complete.

-----------

 

But I do see vspread.conf in catalog directory but not sure how to configure it.

 

Comments

  • Hi

     

    Since you are running on AWS request you to kindly run below command (-T -N required in the cloud) & let us know if it still fails:

     

    Run this:

    /opt/vertica/sbin/update_vertica -s host1,host2,host3 -r ./v/vertica-7.1.1-0.x86_64.RHEL5.rpm -u vertica -T -N --failure-threshold NONE

     

    In place of:

    /opt/vertica/sbin/update_vertica -s host1,host2,host3 -r ./v/vertica-7.1.1-0.x86_64.RHEL5.rpm -u vertica -T --failure-threshold NONE

     

    Also I hope you are installing this on dev/test cluster.If its a prod one I would recommend not to use "failure-threshold NONE"  and resolve the warnings if comes any.

     

    Regards

    Rahul Choudhary

  • I believe that the installer will tell you to use -T on AWS if you let it validate your environment for you -- using a failure threshold of NONE suppresses those helpful warnings.

     

     

  • It looks like that command didn't update any files. I see the following message:

    No spread upgrade required: /opt/vertica/config/vspread.conf not found on any node

    ---------

    There is one vspread.conf and it's contents are:

    /opt/vertica/agent/test/config/vspread.conf

    Spread_Segment 127.255.255.255:4803 {
    N127000000001 127.0.0.1 {
    127.0.0.1
    }
    }
    EventLogFile = /dev/null
    EventTimeStamp = "[%a %d %b %Y %H:%M:%S]"
    DaemonUser = spread
    DaemonGroup = verticadba
    DebugFlags = { EXIT }

    ------------


    [[email protected] ~]$ ps -eaf|grep spread
    vertica 4192 1 0 12:48 pts/0 00:00:00 /opt/vertica/spread/sbin/spread -c /home/vertica/test/v_test_node0001_catalog/spread.conf

    There is spread.conf that I think spread is using and it's contents are:

    # 1
    # Auto-generated by vertica - do not edit
    ActiveIPVersion = IPv4
    Spread_Segment 10.241.251.220:4803 {
    N010241251220 10.241.251.220 {
    10.241.251.220
    }
    }
    # begin end matter
    EventLogFile = /dev/null
    EventTimeStamp = "[%a %d %b %Y %H:%M:%S]"
    DebugFlags = { PRINT EXIT }
    ExitOnIdle = yes

  • SruthiASruthiA Employee

    Hi,

     

      As far as I know, That warning message may not cause any problems to your AWS cluster. DId you try creating a database and perform some operations on it?

     

    -Regards,

     Sruthi

  • After vertica 7 the spread config file is in catalog. Once that the database is created to change from broadcast ( default setting) to point to point ( the -T) option,  you need to execute


    •select set_control_mode('pt2pt');
    •select reload_spread(true);

     

    To go back to broadcast is

    • select set_control_mode('broadcast');

     

    Your database may go down while doing the reload, or if does not you should restart the cluster. You can check that the change happen by looking at the spread.conf file that is on your catalog directory.

    if it is broadcast you will have un spread segment, it it is point to point, you will have one segment per node.

     

    HTH.

     

    Eugenia

  • On a related node, what is the proper procedure to migrate a 7.x HP Vertica cluster from a set of IPs to another one? The cluster was incorrectly configured using public IPs and I would like to change them to private. Given the changes in Vertica 7.x , it would be nice to have this procedure documented. 

  • Yes, for now the process of changing IP is with Support Assistance as it needs to change the catalog objects before. 

     

    Eugenia

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.