Vertica client versions 8.1 and 9.1 fail to install in Windows 10 Pro 64-bit

I have been trying to install either version 8.1.1 or 9.1.1 of Vertica client software for 64-bit Windows. I have the very latest version of Windows 10 Pro, version 1803, build 17134.345. (Note that Windows version 1809 has been recalled due to bugs.)

I have Microsoft .Net Framework 4.7.2 SDK installed as well.

I tried installing 8.1.1 first, but it never worked. It just says "installation failed", and there is some cryptic error in one of the log files, which is hard to find. Others have posted about this in the forums.

Then I tried to install 9.1.1, and the install was a bit different. The first thing it does is tell you to accept and install .Net Framework. (Note that it doesn't even tell you which version it's going to install.) If you hit Accept, it brings you to a second, similar screen, where you must accept again. At this point, I refused because it was going to install .Net Framework 3.5, which I don't want. (All apps made for 3.5 can run on 4.5 or later, if the developer would simply specify that it can when building.)

Now I cannot install either version at all. If I try to install 8.1.1, it says I already have a later version installed, but I do not. There is no Vertica software visible anywhere in WIndows or in Program Files. Even worse, if I try to now install 9.1.1, it brings up an empty window with only this text at the top: "Microsoft .NET Framework required for Vertica Client Installer setup". There are no checkboxes or anything else in this window, so the only choice is to close it.

All I want is an updated version of vsql.exe. Should it be so difficult?.


  • verticauser810verticauser810 Vertica Customer

    I had to give in and install .Net Framework 3.5 in order to complete the installation of client software version 9.1.1. But of course this latest version of Windows Pro won't install .Net 3.5 from by enabling it in Windows Features, nor by going to Windows Update, nor by downloading the web installer for it, nor by by downloading the 235 MB executable installer for dotNetFX35. So I had to download Windows Media Creator which allowed me to download an ISO image of Windows installer, from which I could then install .Net Framework 3.5 manually using a command like this:

    Dism /online /enable-feature /featurename:NetFX3 /All /Source:D:\sources\sxs /LimitAccess

    Now I finally have that 2 MB file, vsql.exe.

  • I got the same problem but I did a restore previous restore point to avoid that issue with version 9.1 and the issue keep asking to install .Net Framework 3.5 … so I am back to trying to install version 8.0 but again keep failing as before any idea how to pass that issue? I did tried to install .Net Framework 3.5 but it would not do it because windows was saying it has a newer version. I am not sure what is preventing to install the driver I have a desktop with same version of windows and I did not have any problems but that one has some other software like Visual Studio not sure if that would make a difference or not any suggestion would be appreciated

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file