cannot access database because of MaxClientSessions = 0;

avi120avi120 Registered User

Hi Experts

I ran the following command because I wanted to to stop the database and did not want to have open sessions

vsql -U vertica -c "ALTER DATABASE aaa SET MaxClientSessions = 0;"

What I did not expect is that I will not be able to change this configuration. I keep getting "New session rejected due to limit, already 5 sessions active".

How can I get out of this?
What is the correct way to gracefully terminate open sessions and prevent new ones from opening? I do not want to use the -F option when stopping the database

Thanks!

Comments

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file