Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

MC fails to show correcty DB state

Hi!
Since yesterday I have been encountering a problem with my MC.It is showing a wrong DB state.My DB is up and running in command line and I can see in admintools as UP but MC shows it as down.I have tried restarting the agent with sudo /opt/vertica/sbin/vertica_agent restart..I also tried to use another browser (cache issues) and clear all the cache on the linux + followed the vertica clear cache in the documentation + restarted the console. nothing helped.
So annoying...any ideas?
Vertica Analytic Database v9.3.0-0 with MC 9 .3

Answers

  • Is MC and vertica running on same cluster?
    Can you run
    rpm -qa| grep vertica
    ps -ef | grep vertica
    Have you checked the MC log.
    Have you tried running vertica-consoled
    /etc/init.d/vertica-consoled start

  • Thanks for your response.
    To answer all your questions:
    The vertica is running on the same cluster as the MC .
    rpm -qa| grep vertica:
    Command 'rpm' not found, but can be installed with:
    apt install rpm
    ps -ef | grep vertica:
    s=true -Duser.language=en -Dvertica.home=/opt/vertica -Dvconsole.home=/opt/vconsole -Djava.library.path=/opt/vconsole/lib -Dderby.system.home=/opt/vconsole/mcdb/derby -Dorg.eclipse.jetty.annotations.LEVEL=OFF -Xmx2g -Xms1g -jar /opt/vconsole/lib/webui.war
    dbadmin 2575 1 0 12:02 ? 00:00:00 /bin/bash /opt/vertica/agent/agent.sh /opt/vertica/config/users/dbadmin/agent.conf
    dbadmin 2612 2575 0 12:02 ? 00:00:15 /opt/vertica/oss/python3/bin/python3 ./simply_fast.py
    472 2878 2664 0 12:02 ? 00:00:00 /var/lib/grafana/plugins/vertica-grafana-datasource/dist/vertica-grafana-datasource_linux_amd64
    dbadmin 3806 1 0 12:04 ? 00:00:07 /opt/vertica/spread/sbin/spread -c /vertica-data/rubyplay/v_rubyplay_node0001_catalog/spread.conf -D /opt/vertica/spread/tmp
    dbadmin 3808 1 0 12:04 ? 00:02:47 /opt/vertica/bin/vertica -D /vertica-data/rubyplay/v_rubyplay_node0001_catalog -C rubyplay -n v_rubyplay_node0001 -h 127.0.0.1 -p 5433 -P 4803 -Y ipv4
    dbadmin 4176 1 0 12:08 ? 00:02:44 /opt/vertica/bin/vertica -D /vertica-data/Rubyplay_BI/v_rubyplay_bi_node0001_catalog -C Rubyplay_BI -n v_rubyplay_bi_node0001 -h 127.0.0.1 -p 5433 -P 4803 -Y ipv4
    dbadmin 4356 4176 0 12:11 ? 00:00:08 /opt/vertica/bin/vertica-udx-zygote 11 9 4176 debug-log-off /vertica-data/Rubyplay_BI/v_rubyplay_bi_node0001_catalog/UDxLogs 60 12 0
    dbadmin 4359 3808 0 12:11 ? 00:00:08 /opt/vertica/bin/vertica-udx-zygote 11 9 3808 debug-log-off /vertica-data/rubyplay/v_rubyplay_node0001_catalog/UDxLogs 6012 0
    root 173154 172738 0 19:32 pts/0 00:00:00 grep --color=auto vertica
    Have you checked the MC log? ofcourse - nothing there
    It is showing the database but in a DOWN state even though it is up.
    --Have you tried running vertica-consoled? ofcourse , a couple of times including to restart the agent.

    Please advise further.... Thanks!!!

  • @kfruchtman Can you share the MC log? Without the log it's hard to find why MC not showing the right status of the DB?
    Can you also run the below command
    admintools -t db_status -s up

  • edited March 2021

    Sure:

    [email protected]:~$ admintools -t db_status -s up
    rubyplay
    attaching the MC log:

  • edited March 2021

    11

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.