The Vertica Forum recently got a makeover! Let us know what you think by filling out this short, anonymous survey.

about vertica ERROR 5001

Hi,
   today, I got a   error 'ERROR 5001' when running a sql in vertica. please refer the below info

test=> select * from resource_usage;

ERROR 5001:  ThreadManager failed to create thread EEcmdq: boost::thread_resource_error

HINT:  Please raise the number of processes per user

My question is how to raise the number of processes per user? which database parameter should i change?


Comments

  • Hi,

    First thing to check would be the nproc kernel setting in the /etc/security/limits.conf file. That controls the number of threads available to a user. See the Installation Guide section on Kernel parameters for complete details. extract from the table of kernel params:
    /etc/security/limits.conf
    NPROC

    Total RAM on the node in MB (e.g., on 1GB machine, set NPROC to 1000) Controls the maximum number of threads and processes for each user.

    During install Vertica will add a couple entries in the limits file. So look for the current setting and see if it's in line with the formula above or not. If not adjust accordingly.

    # Added by Vertica
    dbadmin soft nproc 65536
    # Added by Vertica
    dbadmin hard nproc 65536

    Hope it helps.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.